Package does not load correctly

Topics: Bugs
May 31, 2016 at 2:25 PM
I'm attempting to load RedmineTaskList in Visual Studio 2010, using the extension manager. The package downloads and installs correctly, but fails to initialise:
The 'RedmineTaskListPackage' package did not load correctly.

The problem may have been caused by a configuration change or by the installation of another
extension. You can get more information by running the application together with the /log
parameter on the command line, and then examining the file
'C:\Users\jelliott\AppData\Roaming\Microsoft\VisualStudio\10.0\ActivityLog.xml'.
The entries in ActivityLog.xml are:
91 Begin package load [RedmineTaskListPackage] {97535913-77A4-4D2A-BA30-6C4702D8EC5C} VisualStudio
92 ERROR CreateInstance failed for package [RedmineTaskListPackage] {97535913-77A4-4D2A-BA30-6C4702D8EC5C} 80070002 VisualStudio 2016/05/31 14:06:57.766
93 ERROR End package load [RedmineTaskListPackage] {97535913-77A4-4D2A-BA30-6C4702D8EC5C} 80004005 - E_FAIL VisualStudio
The same error appears if I attempt to open the configuration screen in Options.
Jul 22, 2016 at 1:35 PM
Edited Jul 22, 2016 at 1:37 PM
I'm having the same problem. I only have VS2010 installed (not 2012+) and these are my log entries in ActivityLog.xml:
  <entry>
    <record>78</record>
    <time>2016/07/22 13:28:58.192</time>
    <type>Information</type>
    <source>VisualStudio</source>
    <description>Begin package load [RedmineTaskListPackage]</description>
    <guid>{97535913-77A4-4D2A-BA30-6C4702D8EC5C}</guid>
  </entry>
  <entry>
    <record>79</record>
    <time>2016/07/22 13:28:58.212</time>
    <type>Error</type>
    <source>VisualStudio</source>
    <description>CreateInstance failed for package [RedmineTaskListPackage]</description>
    <guid>{97535913-77A4-4D2A-BA30-6C4702D8EC5C}</guid>
    <hr>80070002</hr>
    <errorinfo>Die Datei oder Assembly "Microsoft.VisualStudio.Shell.11.0, Version=11.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" oder eine Abhängigkeit davon wurde nicht gefunden. Das System kann die angegebene Datei nicht finden.</errorinfo>
  </entry>
  <entry>
    <record>80</record>
    <time>2016/07/22 13:28:58.212</time>
    <type>Error</type>
    <source>VisualStudio</source>
    <description>End package load [RedmineTaskListPackage]</description>
    <guid>{97535913-77A4-4D2A-BA30-6C4702D8EC5C}</guid>
    <hr>80004005 - E_FAIL</hr>
    <errorinfo>Die Datei oder Assembly "Microsoft.VisualStudio.Shell.11.0, Version=11.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" oder eine Abhängigkeit davon wurde nicht gefunden. Das System kann die angegebene Datei nicht finden.</errorinfo>
  </entry>
It seems it's trying to load libraries from VS2012 (if that is version 11.0), specifically VisualStudio.Shell. Was it maybe compiled with a newer version which breaks backward compatiblity?